[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [TYPO3-german] TYPO3 6.2: Uncaught TYPO3 Exception: PHP Warning: session_start(): Function spl_autoload_call() hasn't defined the class it was called for in []typo3/sysext/backend/Classes/Controller/LoginController.php on line 147



Hallo Arne-Kolja,

nein, bei mir ist alles in Ordnung.

Gruß
Stefan

Am 01.10.2015 um 12:02 schrieb Arne-Kolja Bachstein:
> Hallo Stefan,
> 
> ich habe gerade das Problem scheinbar auch. Ich habe gestern mein Projekt 
> irgendwie etwas wild ver-git-et, deshalb hoffe ich, dass das folgende nicht 
> daran liegt:
> 
> Bei mir ist der Extension-Ordner „kaputt“. Die Dateinamen enthalten 
> Backslashes inkl. Ordnernamen, so dass gar keine Ordnerhierarchie mehr 
> existiert. Sehr weird. Ist das bei Dir auch so, oder liegt das an meiner 
> gestrigen Git-Spielerei?
> 
> ArneKoljasiMac:t3adminer arne$ ls -lha
> total 1448
> drwxrwsr-x  33 arne  staff   1,1K 30 Sep 14:35 .
> drwxr-xr-x  14 arne  staff   476B 30 Sep 17:31 ..
> -rw-rw-r--   1 arne  staff   3,7K 30 Sep 14:35 ChangeLog
> -rw-r--r--   1 arne  staff    10K 30 Sep 14:35 
> Classes\Controller\AdminerController.php
> -rw-r--r--   1 arne  staff   1,5K 30 Sep 14:35 
> Classes\Hooks\T3AdminerHooks.php
> -rw-rw-r--   1 arne  staff   318B 30 Sep 14:35 README.txt
> -rw-r--r--   1 arne  staff   170B 30 Sep 14:35 Resources\Public\Icons\add.png
> -rw-r--r--   1 arne  staff   161B 30 Sep 14:35 
> Resources\Public\Icons\delete_black.png
> -rw-r--r--   1 arne  staff   169B 30 Sep 14:35 
> Resources\Public\Icons\delete_white.png
> -rw-r--r--   1 arne  staff   142B 30 Sep 14:35 Resources\Public\Icons\down.png
> -rw-r--r--   1 arne  staff   3,1K 30 Sep 14:35 
> Resources\Public\Icons\module-adminer.png
> -rw-r--r--   1 arne  staff   381B 30 Sep 14:35 
> Resources\Public\Icons\sprite.png
> -rw-r--r--   1 arne  staff   148B 30 Sep 14:35 Resources\Public\Icons\up.png
> -rw-r--r--   1 arne  staff   181K 30 Sep 14:35 doc\manual.sxw
> -rw-rw-r--   1 arne  staff   406B 30 Sep 14:35 ext_conf_template.txt
> -rw-rw-r--   1 arne  staff   2,2K 30 Sep 14:35 ext_emconf.php
> -rw-rw-r--   1 arne  staff   101B 30 Sep 14:35 ext_icon.gif
> -rw-rw-r--   1 arne  staff   3,1K 30 Sep 14:35 ext_icon.png
> -rw-rw-r--   1 arne  staff   252B 30 Sep 14:35 ext_localconf.php
> -rw-rw-r--   1 arne  staff   413B 30 Sep 14:35 ext_tables.php
> -rw-r--r--   1 arne  staff   486B 30 Sep 14:35 mod1\conf.php
> -rw-r--r--   1 arne  staff   253B 30 Sep 14:35 mod1\index.php
> -rw-r--r--   1 arne  staff   784B 30 Sep 14:35 mod1\locallang.xml
> -rw-r--r--   1 arne  staff   516B 30 Sep 14:35 mod1\locallang_mod.xml
> -rw-r--r--   1 arne  staff   101B 30 Sep 14:35 mod1\moduleicon.gif
> -rw-r--r--   1 arne  staff    17K 30 Sep 14:35 res\adminer.css
> -rw-r--r--   1 arne  staff   394K 30 Sep 14:35 res\adminer.txt
> -rw-r--r--   1 arne  staff   664B 30 Sep 14:35 res\plugins\AdminerFrames.php
> -rw-r--r--   1 arne  staff   1,9K 30 Sep 14:35 
> res\plugins\dump-save-server.php
> -rw-r--r--   1 arne  staff   524B 30 Sep 14:35 res\plugins\links-direct.php
> -rw-r--r--   1 arne  staff   7,7K 30 Sep 14:35 res\plugins\plugin.php
> -rw-r--r--   1 arne  staff   488B 30 Sep 14:35 
> res\plugins\version-noverify.php
> -rw-r--r--   1 arne  staff   3,4K 30 Sep 14:35 res\t3adminer.php
> 
> 
>> Am 01.10.2015 um 08:36 schrieb Stefan Padberg 
>> <[email protected]>:
>>
>> Am 18.09.2015 um 17:50 schrieb Ralf-Rene Schröder:
>>> Am 18.09.2015 um 14:39 schrieb Stefan Padberg:
>>>> ich glaube es hängt mit der Extension 'phpmyadmin' zusammen. 
>>>
>>> probier mal den t3adminer, der war bei mir immer deutlich unkritischer
>>>
>>
>> Hallo Ralf-Rene,
>>
>> das kann ich leider nicht bestätigen. Ich habe Version 1.4.1
>> installiert, was die jüngste für TYPO3 6.2.x ist.
>>
>> Im Backend erzeugt sie einen dicken Fehler:
>> Fatal error: TYPO3\CMS\Core\Utility\GeneralUtility::requireOnce():
>> Failed opening required
>> '/var/www/web14/html/typo3_neu/typo3/typo3conf/ext/t3adminer/classes/class.tx_t3adminer_hooks.php'
>> (include_path='/var/www/web14/html/typo3_neu/typo3/typo3/contrib/pear/:.:/usr/share/php:/usr/share/pear')
>> in
>> /var/www/web14/html/typo3_neu/typo3/typo3_src-6.2.15/typo3/sysext/core/Classes/Utility/GeneralUtility.php
>> on line 4739
>>
>> Ich muss die Extension wieder deinstallieren.
>>
>> Gruß
>> Stefan
>> _______________________________________________
>> TYPO3-german mailing list
>> [email protected]
>> http://lists.typo3.org/cgi-bin/mailman/listinfo/typo3-german
> 

_______________________________________________
TYPO3-german mailing list
[email protected]
http://lists.typo3.org/cgi-bin/mailman/listinfo/typo3-german