[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [TYPO3-english] server error after update to TYPO3 4.6.0beta3



Hi Thanks for your ideas

The server is running PHP 5.3 and Debian 6 all up to date
TYPO3 sites 4.5.6 work perfect
like usual we uploaded the source
like usual we changed the symlink
like usual we deleted the typo3temp and temp files in typo3_conf
I assume that no additional php modules are required and the site should run
with the same php  settings like in 4.56 and there we have no problems at
all!

We installed 4.6 only to test out ad to have a look to the backend!

in Frontend as soon as we change symlink to the new source - when we change
back site is working perfect again
HTTP Error 500 (Internal Server Error): An unexpected condition was
encountered while the server was attempting to fulfill the request.

The only screen you get is the one that the install tool is disabled but as
soon as you fill in the enabled file you get again the server error like in
the front and backend.

[Mon Oct 03 19:18:06 2011] [error] [client 111.111.111.111] PHP Fatal
error:  Class 't3lib_utility_VersionNumber' not found in
/path/typo3_src-4.6.0beta3/t3lib/class.t3lib_div.php on line 887
[Mon Oct 03 19:21:46 2011] [error] [client 111.111.111.111] PHP Fatal
error:  Class 't3lib_utility_VersionNumber' not found in
/path/typo3_src-4.6.0beta3/t3lib/class.t3lib_div.php on line 887,
referer: http://domain.tld/typo3/
[Mon Oct 03 19:23:39 2011] [error] [client 111.111.111.111] PHP Fatal
error:  Class 't3lib_utility_VersionNumber' not found in
/path/typo3_src-4.6.0beta3/t3lib/class.t3lib_div.php on line 887,
referer: http://domain.tld/typo3/install/

Version number is missing it is said

in localconf.php we have
$TYPO3_CONF_VARS['SYS']['compat_version'] = '4.5';

Andi



On Mon, Oct 3, 2011 at 4:46 PM, Jigal van Hemert <[email protected]> wrote:

> Hi,
>
>
> On 3-10-2011 11:25, Philipp Gampe wrote:
>
>> Andreas Becker wrote:
>>
>>> we wanted to try Version 4.6.0 but always get a servererror while testing
>>> the 4.6.0beta3 source, we not even ca't access the install tool. With
>>>
>> A few guesses:
>>
>> * you are running a PHP version below 5.3
>>
>
> This would give the message "TYPO3 requires PHP 5.3.0 or higher."
>
>
>  * you have some strange PHP settings (session?)
>> * you do not have all required PHP modules
>>
>
> This is tested in the early stages of the 1-2-3 Installer.
>
>
>  * some files do not have the execute permission (or not the read
>> permission)
>> * you did not remove the typo3conf/temp_* files
>> * you did not remove typo3temp/*
>>
>> Although, the last ones are really unlikely because the Install Tool
>> should
>> handle that.
>>
>
> True.
>
> Conclusion: the error message seems necessary.
>
>
> --
> Kind regards / met vriendelijke groet,
>
> Jigal van Hemert.
> _______________________________________________
> TYPO3-english mailing list
> [email protected]
> http://lists.typo3.org/cgi-bin/mailman/listinfo/typo3-english
>
_______________________________________________
TYPO3-english mailing list
[email protected]
http://lists.typo3.org/cgi-bin/mailman/listinfo/typo3-english