[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [TYPO3-english] Typo3 RTE configuration: class saved to the database, but will be removed in the frontend website



 I might better post the whole RTE configuration:

## Default RTE configuration
RTE.default {
  contentCSS = fileadmin/templates/css/rte.css
   ## Markup options (htmlArea RTE only)
    enableWordClean = 1
    removeTrailingBR = 1
    removeComments = 1
    removeTags = center, font, o:p, sdfield, strike, u
    removeTagsAndContents = link, meta, script, style, title
## Use stylesheet file rather than the above mainStyleOverride and inlineStyle properties to style the contents (htmlArea RTE only). ## When RTE.default.contentCSS is not specified, file EXT:rtehtmlarea/res/contentcsss/default.css is used.
    ignoreMainStyleOverride = 1
## Use stylesheet file rather than the above mainStyleOverride and inlineStyle properties to style the contents (htmlArea RTE only). ## When RTE.default.contentCSS is not specified, file EXT:rtehtmlarea/res/contentcsss/default.css is used.
    ignoreMainStyleOverride = 1

## List all class selectors that are allowed on the way to the database
    allowedClasses (
external-link, external-link-new-window, internal-link, internal-link-new-window, download, mail,
        align-left, align-center, align-right, align-justify,
        csc-frame-frame1, csc-frame-frame2,
        component-items, action-items,
        component-items-ordered, action-items-ordered,
        important, name-of-person, detail,
        indent, sortedTable
    )
    proc.allowedClasses < RTE.default.allowedClasses
    FE.proc.allowedClasses < RTE.default.allowedClasses
    proc.HTMLparser_rte.allowTags < RTE.default.allowedClasses
    proc.entryHTMLparser_db < RTE.default.allowedClasses
## Configuration specific to the TableOperations feature (htmlArea RTE only)
        ## Remove the following fieldsets from the table operations dialogs
    disableAlignmentFieldsetInTableOperations = 1
    disableSpacingFieldsetInTableOperations = 1
    disableColorFieldsetInTableOperations = 1
    disableLayoutFieldsetInTableOperations = 1
    disableBordersFieldsetInTableOperations = 1
        ## Show borders on table creation
    buttons.toggleborders.setOnTableCreation = 1

## Configuration specific to the bold and italic buttons (htmlArea RTE only)
        ## Add hotkeys associated with bold and italic buttons
    buttons.bold.hotKey = b
    buttons.italic.hotKey = i
)


Am 02.10.2010 11:35, schrieb Marco Weber:
 Hi,

Thanks for your reply.
First i made your changes and flushed all cashes. But there was still the same problem. Then i've googled for the keyword "RTE.default.FE.proc.allowedClasses".
An i  tried the following lines:
    RTE.default.allowedClasses (
external-link, external-link-new-window, internal-link, internal-link-new-window, download, mail,
        align-left, align-center, align-right, align-justify,
        csc-frame-frame1, csc-frame-frame2,
        component-items, action-items,
        component-items-ordered, action-items-ordered,
        important, name-of-person, detail,
        indent, sortedTable
    )
    # desperatly trying to get it work! ;)
    RTE.default.proc.allowedClasses < RTE.default.allowedClasses
    RTE.default.FE.proc.allowedClasses < RTE.default.allowedClasses
RTE.default.proc.HTMLparser_rte.allowTags < RTE.default.allowedClasses
    RTE.default.proc.entryHTMLparser_db < RTE.default.allowedClasses

After that, i flushed all caches, but there is still the same Problem with typo3 4.4.2 ... I can select the the classes in the RTE and they will be saved to the database, but they will be removed in the HTML of the frontend website.
Do you know anything else?
Is there something more i have to configure within "RTE.default.FE" ?
Is there anywhere a documentation about the parameters that are available under "RTE.default.FE"?

Thanks a lot in advance... :)

see you
        Marco


Am 01.10.2010 23:49, schrieb Philippe Moreau:
Try to add your class to RTE.default.FE.proc.allowedClasses as well.



On Fri, Oct 1, 2010 at 12:02 PM, Marco Weber<[email protected]>wrote:
  Hi,

I've a simple problem with the RTE. I can use the sortedTable class, an the
RTE saves it to the mysql. But typo3 doesn't show it on the frontend
website.
( the html looks like this:<table class="">  ... )

i've added sortedTable to RTE.default.proc.allowedClasses and to
RTE.default.classesTable

What else do i have to write, so that typo3 finally displays the class in
the frontend website?

Thanks in advance,
        Marco Weber


BTW: This is a part of my current RTE configuration:

## List all class selectors that are allowed on the way to the database
    RTE.default.proc.allowedClasses (
        external-link, external-link-new-window, internal-link,
internal-link-new-window, download, mail,
        align-left, align-center, align-right, align-justify,
        csc-frame-frame1, csc-frame-frame2,
        component-items, action-items,
        component-items-ordered, action-items-ordered,
        important, name-of-person, detail,
        indent, sortedTable
    )
## List all class selectors that are allowed on the way to the database
    RTE.default.classesTable = sortedTable, csc-frame-frame1,
csc-frame-frame2
_______________________________________________
TYPO3-english mailing list
[email protected]
http://lists.typo3.org/cgi-bin/mailman/listinfo/typo3-english


_______________________________________________
TYPO3-english mailing list
[email protected]
http://lists.typo3.org/cgi-bin/mailman/listinfo/typo3-english
_______________________________________________
TYPO3-english mailing list
[email protected]
http://lists.typo3.org/cgi-bin/mailman/listinfo/typo3-english