[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [TYPO3-english] Where to set mb_internal_encoding



Hi Nicolai

try set both t3lib_cs_convMethod and t3lib_cs_utils to "mbstring" in BE
InstallTool All configuration.

HTH

Stano.

On Tue, Jun 1, 2010 at 2:50 PM, <[email protected]> wrote:

> Thanks for your answer, Dmitry
>
>
> > [email protected] wrote:
> > > I converted my site to utf-8 and found out that, to work properly, php
> > has to be set to mb_internal_encoding = utf-8.
> >
> > .htaccess?
>
> A good idea. Inserting "php_value mbstring.internal_encoding UTF-8" to
> .htaccess works. But only locally. On the server we don't have the needed
> privileges.
>
> > Where do I have to put it
> > to make it work in BE as well?
> >
> > In the Install tool. See in "All configuration".
>
> I have set [BE][forceCharset] = utf-8 in the install-tool and
> ['SYS']['setDBinit'] = 'SET NAMES utf8' in localconf.php.
> But both don't affect the setting for phps internal_encoding
>
> Is there anything I have missed?
>
> Thanks
> Nicolai
>
>
>
> >
> > --
> > Dmitry Dulepov
> > TYPO3 expert / TYPO3 core&security teams member
> > Twitter: http://twitter.com/dmitryd
> > Read more @ http://dmitry-dulepov.com/
> > _______________________________________________
> > TYPO3-english mailing list
> > [email protected]
> > http://lists.typo3.org/cgi-bin/mailman/listinfo/typo3-english
> _______________________________________________
> TYPO3-english mailing list
> [email protected]
> http://lists.typo3.org/cgi-bin/mailman/listinfo/typo3-english
>
_______________________________________________
TYPO3-english mailing list
[email protected]
http://lists.typo3.org/cgi-bin/mailman/listinfo/typo3-english