[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[TYPO3] Call to undefined function session_start() in /var/www/localhost/htdocs/typo3/index.php on line 240


  • From: martin at hauntedhousecom.net (Martin S)
  • Date: Sun, 01 Jan 2006 20:52:03 +0100

Martin S wrote:

> Martin S wrote:
> 
>> 2006/1/1, Carsten Gehling <carsten.gehling at gmail.com>:
>>>
>>> How did you install PHP? With Gentoo's package manager or through the
>>> source-code?
>>>
>>>
>> emerge dev-lang/php
>> I belive. I found something on the forums mentioning that you need the
>> USE flag "session" for PHP5 so I added it and will see how this works.
>> Now I have to refind the tslib directory... I deleted my htdocs in
>> frustration and now I can't find tslib (as a directory not link) in any
>> of the archives I downloaded...)
> 
> Re-emerged php with the "session" USE-flag.
> Used the zip file and dummy site (rather than tar.gz and dummy site).
> Now I have a working Typo3 system on my laptop...

Much too quick apparently :(
I get lots of mysql errors when actually trying to do something. Like 

Warning: mysql_num_rows(): supplied argument is not a valid MySQL result
resource in /var/www/localhost/htdocs/typo3/t3lib/class.t3lib_db.php on
line 749

Warning: mysql_free_result(): supplied argument is not a valid MySQL result
resource in /var/www/localhost/htdocs/typo3/t3lib/class.t3lib_db.php on
line 786

Warning: Cannot modify header information - headers already sent by (output
started at /var/www/localhost/htdocs/typo3/t3lib/class.t3lib_db.php:749)
in /var/www/localhost/htdocs/typo3/template.php on line 601

I suppose this has to do with my version of MySQL:5.0.18


Martin S