[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [TYPO3-dev] How to keep a extbase extension compatible between TYPO3 versions



I guess you will be more succesful writing on one TYPO3 slack channel
where all deves are concentrated today.

AFAIK there are no specific guidelines that are not common sense.

Personally I take care not using deprecated methods and properties and
when it woths it I encapsulate calls to API in my own classes methods to
isolate them



Il 06/04/2017 08:48, Marcus Bieber ha scritto:
> Hi everybody,
>
> I was wandering if there is a guide/links/tips to find informations
> about what to do to keep a extbase extension compatible through TYPO3
> Versions.
>
> What would be the plan to be compatible for 6.2 LTS, 7 LTS to 8 LTS or
> 7 LTS to 8 LTS
>
> I have a 6.2 extbase extension in some customer projects which will
> update in different times to different Versions. Don't ask.... customers.
> And I'm looking for a good strategy to keep the effort low.
> I couldn't find something official. Is there?
>
> Thanks in advance for any advice.
>
> Regards Marcus
> _______________________________________________
> TYPO3-dev mailing list
> [email protected]
> http://lists.typo3.org/cgi-bin/mailman/listinfo/typo3-dev

-- 
==================================================
dott. Ivano Mario Luberti
Archimede Informatica societa' cooperativa a r. l.
Sede Operativa
Via Gereschi 36 - 56126- Pisa
tel.: +39-050- 580959
tel/fax: +39-050-8932061
web: www.archicoop.it
==================================================


_______________________________________________
TYPO3-dev mailing list
[email protected]
http://lists.typo3.org/cgi-bin/mailman/listinfo/typo3-dev