[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [TYPO3-dev] maxW and maxH in 4.1.2



Hi Steffen,

Steffen Kamper schrieb:
> "Helmut Hummel" <[email protected]> schrieb im Newsbeitrag 
> news:[email protected]
>> Hi Steffen,
>>
>> Steffen Kamper schrieb:
>>> exactly the same. I also checked it with normal CE-Type Text/Pic and Pic.
>> Hard to believe ;)

It's not the same at all. If you use IAMGE object directly (and solely)
through TS all is fine.

>>> check it out here:
>>> http://www.demo.netztool.de/typo3/index.php?u=demo&p=demo101
>>>
>>> On id244 i set image size to 50/50. You see height is 50, but width is 
>>> with
>>> 2 pics more than 50.
> 
> this is standard, nothing special. 

This is standard IMGTEXT, which behaves different.

> It's not my site so i can't see the 
> template. But it's a chance to show the problem.
> As you see it is a normal Text/pic with 3 pictures.

I could reproduce your setup. tt_content.image.20.1.file.maxW is ignored
completely, as the width seems to be calculated based on
tt_content.image.20.maxW (which is the max width of all images).

So the calculated width for an image based on tt_content.image.20.maxW
is not overruled by tt_content.image.20.maxW if set to a smaller value.

But I did not manage to evaluate the code yet, so I don't know if this
is a bug or not.

Oh, this is based on a 4.1.3 installation...

Regards Helmut
_______________________________________________
TYPO3-dev mailing list
[email protected]
http://lists.netfielders.de/cgi-bin/mailman/listinfo/typo3-dev