[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[TYPO3-dev] showpic.php causes DB-errors + possible templating of showpic.php?



Hi list,

I'm a little confused. I just updated to 4.0.1 and noticed that all the images 
with click-enlarge show db-errors in the popup window.


Here the full error messages that appear in every image popup window
----
Warning: mysql_query(): supplied argument is not a valid MySQL-Link resource in 
/usr/local/typo3/htdocs/typo3_src-4.0.1/t3lib/class.t3lib_db.php on line 226

Warning: mysql_fetch_assoc(): supplied argument is not a valid MySQL result 
resource in /usr/local/typo3/htdocs/typo3_src-4.0.1/t3lib/class.t3lib_db.php on 
line 801

Warning: mysql_query(): supplied argument is not a valid MySQL-Link resource in 
/usr/local/typo3/htdocs/typo3_src-4.0.1/t3lib/class.t3lib_db.php on line 226

Warning: mysql_error(): supplied argument is not a valid MySQL-Link resource in 
/usr/local/typo3/htdocs/typo3_src-4.0.1/t3lib/class.t3lib_db.php on line 777

Warning: mysql_fetch_assoc(): supplied argument is not a valid MySQL result 
resource in /usr/local/typo3/htdocs/typo3_src-4.0.1/t3lib/class.t3lib_db.php on 
line 801

Warning: mysql_real_escape_string() expects parameter 2 to be resource, boolean 
given in /usr/local/typo3/htdocs/typo3_src-4.0.1/t3lib/class.t3lib_db.php on 
line 554

Warning: mysql_real_escape_string() expects parameter 2 to be resource, boolean 
given in /usr/local/typo3/htdocs/typo3_src-4.0.1/t3lib/class.t3lib_db.php on 
line 554

Warning: mysql_real_escape_string() expects parameter 2 to be resource, boolean 
given in /usr/local/typo3/htdocs/typo3_src-4.0.1/t3lib/class.t3lib_db.php on 
line 554

Warning: mysql_real_escape_string() expects parameter 2 to be resource, boolean 
given in /usr/local/typo3/htdocs/typo3_src-4.0.1/t3lib/class.t3lib_db.php on 
line 554

Warning: mysql_real_escape_string() expects parameter 2 to be resource, boolean 
given in /usr/local/typo3/htdocs/typo3_src-4.0.1/t3lib/class.t3lib_db.php on 
line 554

Warning: mysql_real_escape_string() expects parameter 2 to be resource, boolean 
given in /usr/local/typo3/htdocs/typo3_src-4.0.1/t3lib/class.t3lib_db.php on 
line 554

Warning: mysql_real_escape_string() expects parameter 2 to be resource, boolean 
given in /usr/local/typo3/htdocs/typo3_src-4.0.1/t3lib/class.t3lib_db.php on 
line 554

Warning: mysql_real_escape_string() expects parameter 2 to be resource, boolean 
given in /usr/local/typo3/htdocs/typo3_src-4.0.1/t3lib/class.t3lib_db.php on 
line 554

Warning: mysql_real_escape_string() expects parameter 2 to be resource, boolean 
given in /usr/local/typo3/htdocs/typo3_src-4.0.1/t3lib/class.t3lib_db.php on 
line 554

Warning: mysql_real_escape_string() expects parameter 2 to be resource, boolean 
given in /usr/local/typo3/htdocs/typo3_src-4.0.1/t3lib/class.t3lib_db.php on 
line 554

Warning: mysql_query(): supplied argument is not a valid MySQL-Link resource in 
/usr/local/typo3/htdocs/typo3_src-4.0.1/t3lib/class.t3lib_db.php on line 176

Warning: mysql_query(): supplied argument is not a valid MySQL-Link resource in 
/usr/local/typo3/htdocs/typo3_src-4.0.1/t3lib/class.t3lib_db.php on line 226

Warning: mysql_error(): supplied argument is not a valid MySQL-Link resource in 
/usr/local/typo3/htdocs/typo3_src-4.0.1/t3lib/class.t3lib_db.php on line 777

Warning: mysql_fetch_assoc(): supplied argument is not a valid MySQL result 
resource in /usr/local/typo3/htdocs/typo3_src-4.0.1/t3lib/class.t3lib_db.php on 
line 801
----

I also noticed this on a different server with 4.0.

It seems that this error-message is somehow related to the "overhead" of 
initializing a basic typo3-framework in showpic.php that is kept for backwards 
compatibility. After commenting out the lines above the comment that says that 
these lines can be commented out in showpic.php, the errors are gone.

Anybody else noticed this? What is the cause of this, because everything is 
included as 'require_once' etc.



Another thing is: Isn't it possible to implement templating for showpic.php? In 
other words instead of defining body-tags and whatever in TS and passing these 
values in the url - why can't simply a template file be defined in TS or maybe 
the install-tool like for 404-handling? These variables should be available in 
showpic.php, or am I wrong? And for reading the template and substituging 1 
marker there is no need to initiate the whole template-engine. Just a thought.

-- 
Kind regards,
Franz Koch
_______________________________________________
TYPO3-dev mailing list
[email protected]
http://lists.netfielders.de/cgi-bin/mailman/listinfo/typo3-dev